Cosmetic Issue - No activity displayed

Incident Report for Quable Status Page

Resolved

This incident has been resolved.
Posted Apr 16, 2026 - 14:40 CEST

Identified

We are currently aware of an issue regarding activity display.
Processes are still running nonetheless.
Our teams are working on a fix.

We are sorry for the inconvenience.
Posted Apr 16, 2026 - 09:57 CEST
This incident affected: Product Information Manager (PIM > User interface).